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General Information

Introduction

CCIZip 2.0 is a program that adds a new dimension of file management to your Windows
environment.  With the magnitude of Windows software getting bigger every day, it 
becomes annoying to have to shell out to DOS to perform simple file management - like 
zipping a few files.  It is the intent of this program to eliminate all manual shelling to 
DOS and allow the user to perform all archive file management in a simple, easy to use 
Windows program.

Unfortunately, all computer owners must beware of viruses that could infect their 
computers, particularly when downloading archive files.  The programmers at the 
Creative Consortium have decided to support the support virus scanning software also.  
With CCIZip 2.0 you can search the contents of a archive file for viruses without ever 
leaving the Windows application.

The basic functionality of CCIZip 2.0 is not unique.  There are several other shareware 
programs that provide Windows front-ends to archive software and virus scanning 
utilities programs.  However, CCIZip 2.0 offers an unmatched combination of 
functionality and useability.  



Important Startup Information

The CCIZip 2.0 software package assumes that the archive software and virus scan 
utilities are in your DOS environment path.  However, CCIZip 2.0 will, upon intital 
startup, prompt you for the pathnames of the various support programs you intend to use. 
If you do not intend to use a particular support program, leave it's entry empty.  If you 
have a particular support program in your DOS environment path, simply specify the 
program name.  If you do not intend to have a particular support program in your DOS 
Environment path, you must include the pathname in the name of the program.  After 
this, CCIZip 2.0 will store the information in an .INI file so it will always know where to 
find the support programs.

If any of the above information needs to be changed, run the Path Setup option from the 
File menu to inform CCIZip 2.0 where the support programs are now located.



Enhancements

This is Version 2.0 of the first product released by the Creative Consortium.  We listened 
to the comments from users of 1.0 and have incorporated many new features in 2.0:

We have augmented the file management functionality -- you can now copy, 
move, delete, rename, and duplicate files and directories.

We have extended the archive protocols supported by CCIZip 2.0 -- you can now 
ZIP, ARC, PAK, ZOO, ARJ, and UUEncode/UUDecode.

We have implemented generic Scan funcionality  -- you can now specify a file
(even a batch file) to execute a scan, removing CCIZip 2.0 previous dependency 
on McAfee Virus Utilities.

We have added a Path Setup dialog box which will start up on inital use of 
CCIZip 2.0 -- you no longer have to make sure your archive software and virsu 
scanning software are in your DOS path.

All of these enhancements have also led us to a new action-oriented drag-and-drop 
interface for CCIZip 2.0 -- most file management functions can be performed with a 
simple drag-and-drop.  Also, both Browsers now have the same functionality -- CCIZip 
2.0 considers archive files to be just another level in the normal file/directory tree 
hierarchy.  You can now manage files within archives just as you would normal files in a 
directory.

We consider the items above to be the advantage CCIZip 2.0 has over other Archive 
Managers.  However, we are still interested in hearing your comments about this 
program.  We consider all comments and suggestions.  So please give us call.

Thank you,

The Creative Consortium
P.O Box 47745
Oak Park, MI 48237
(313)589-8247



Usage Information

CCIZip 2.0 is a very simple program to use.  The CCIZip 2.0 window consists of three 
elements.  These are:

Receptacles:

The CCIZip 2.0 Window contains many recessed icons.  These recessed icons 
are called receptacles, so called because they are the recipients of drags.  When 
an item is dragged into a receptacle, an action takes place.  There are 6 different 
receptacles in CCIZip 2.0; they are the Compress, Uncompress, Delete, Arhive 
View, Scan, and Convert receptacles.

Browsers:

The CCIZip 2.0 Window contains 2 listboxes, Compress and Uncompress 
receptacles, a status bar, and a drive selector.  These are all grouped in a shaded 
border.  These areas are called the Browser, so called because they are how one 
browses through the file hierarchy in CCIZip 2.0.

Popup Menus:

The Browsers and the filenames in the Browser's listbox have popup menus that 
are activated when you click on them with the right mouse button.  They are 
called the Browser and File Popups, respectively.  The Browser Popup is 
activated by clicking the right mouse button in the grey area of the one of the 
Browsers.  The File Popups are activated by clicking the right mouse button on 
one of the filenames in the Browser's listbox.  These menus allow you to do 
some special commands such as moving groups of files, running PKZipFix on 
ZIP files, 
duplicating and renaming files...



Registration

CCIZip 2.0 is not free.  If you continue to use this program after 30 days
it is required that you send $33 dollars to:
 

The Creative Consortium
P.O Box 47745
Oak Park, MI 48237

Registering CCIZip 2.0 does not register the PKZip, LHArc, Zoo, Pak, and Arc programs
also!!

Site Licenses are available.

Why should you register this program?

1.  Free technical phone support (313-589-8247).  

2.  It is cheaper, more functional, and easier to use than other
  similar programs.



Procedures

Browser Usage

Following are the different elements that are contained in a file browser (from top to 
bottom):

Current File/Directory Name

This window displays the name of the current directory in the file browser.  If an
archive file is open, the name of the open file will be displayed.

Compress/Uncompress Receptacles

Drag files to the Compress and Uncompress Receptacles (See Receptacle 
Usage) to compress or uncompress files in the current file browser.

Drive Selector

Click on the down-arrow of this window to display a list of all active DOS 
Drives.  Select a drive switch the file browser to the current directory of the 
selected drive.

Listbox

This window displays the contents of the current directory of the file browser or 
the contents of an open archive file.  Files from the listbox can be dragged to the
Receptacles (See Receptacle Usage) or another listbox to perform file or archive
management.  Double click on an archive file to open it and display its contents. 
Double clicking a directory will switch to that directory.  Double clicking any 
other file will try to execute that file if it is an executable, or find an associated 
application otherwise.

File Size Display

This window displays the size of all selected files.  Directories count as a size of
zero.  If an archive file is open, the size is the size of the file if it were to be 
uncompressed.



Mouse Usage

CCIZip 2.0 adds the dimensions of mouse usage that are found in most modern programs.
The first of these features is Drag and Drop.  Selected files from either of the listboxes 
can be dragged to another listbox, or any of the available Receptacles.  This drag and 
drop technique can be used as a replacement for using the Pull down menus.  The second 
feature is Popup Menus.  By clicking the right mouse button on a file or on the empty 
spaces of the Browser, you will be presented with a quick list of items that are releated to 
the specific area you clicked on.



Receptacle Usage

All actions using receptacles are initiated by dragging a group of selected files to the 
receptacle (See Mouse Usage).

There is one compress receptacle for each browser.  Dragging files to the compress 
receptacle will add those files to an archive file.  If an archive file is open in that 
receptacle, the files will be added to the archive file using the options specified for the 
archive program.  Otherwise, you will be prompted to enter a new archive file name.

There is one uncompress receptacle for each browser.  Dragging files to the uncompress 
receptace will uncompress files to the directory of the browser that contains the 
receptacle.  The destination browser must be in file viewing mode (i.e. an arhive file can 
not be open).  If a list of archive files is dragged to the receptacle, each archive file will 
be completely uncompressed using the options specified for each archive program.  
Otherwise, the selected files within an open archive file will be uncompressed.

Dragging files to the delete receptacle will cause those files to be deleted.  If a directory 
is dragged, that directory and all of its subdirectories will be deleted.  If selected files 
from an open archive file are dragged, those files will be removed from the archive file.

Dragging archive files to the scan receptacle will cause the archive files to be 
uncompressed in a temporary directory, that directory will then be scanned for viruses 
using the selected scanning program.  The temporary directory will then be removed.

Dragging archive files to the view receptacle will view the contents of that archive file.  
If selected files from an open archive file are dragged, the contents of those files will be 
displayed.  NOTE:  View should only be used on ASCII files.

Dragging archive files to the convert receptacle will convert those archive files to the 
format of another archive program.



Commands

File Menu

The following commands are available from the File Menu:

Copy

Choose Copy from the File Menu to make a copy of the selected files in the opposite 
browser.  If the selected files are in an open archive file, those files will be uncompressed 
into the opposite browser.

This menu item has the same affect as dragging a group of selected files to the opposite 
browser.

Move

Choose Move from the File Menu to move  the selected files to the opposite browser.  

Rename

Choose Rename from the File Menu to change the file name of the currently selected file.

Delete

Choose Delete from the File Menu to delete  the selected files.  If the selected files are in 
an open archive file, those files will removed from that archive file.

This menu item has the same affect as dragging a group of selected files to the Delete 
Receptacle.

Duplicate

Choose Duplicate from the File Menu to make a duplicate copy of the selected file. 

Compress

Choose Compress from the File Menu to compress the selected files into an archive file 
in the opposite browser.  If the opposite browser already has an archive file open, the 
selected files will be added to that archive file.

This menu item has the same effect as dragging the selected files to the compress 
receptacle in the opposite browser.



Uncompress

Choose Uncompress from the File Menu to uncompress the selected files of an open 
archive file into the current directory of the opposite browser.  

This menu item has the same effect as dragging the selected files to the uncompress 
receptacle in the opposite browser.

Scan

Choose Scan from the File Menu to run the virus scanning software against the currently 
selected archive file.  The archive file will be uncompressed in a temporary directory and 
the contents of that archive file will be scanned.

This menu item has the same effect as dragging a group of archive files to the Scan 
Receptacle. 

Convert

Choose Convert from the File Menu to convert a group of selected archive files  to 
another archive file format.  (i.e.  Convert a ZIP file to an ARJ file).

This menu item has the same effect as dragging a group of archive files to the Convert 
Receptacle.

Archive View

Choose Archive View from the File Menu to display a detailed description of the contents
of an group of selected archive files.  If an archive file is already open, then choosing this
menu item will display the text contents of the selected files within the Archive File.

Choosing this menu item has the same effect as dragging a group of selected files to the 
Archive Receptacle.

Special

Choosing Special from the File Menu displays a sub-menu of functions that can be 
performed on certain Archive File formats.  These special functions are not applicable to 
all archive file formats.

Comment:

Choosing Comment from the Special sub-menu will allow you to add comments to 
each of the files contained within the currently selected archive file.



Self Extracting:

Choosing Self Extracting from the Special sub menu will allow you to convert the 
currently selected archive file into a self extracting archive file.

Fix:

Choosing Fix from the Special sub-menu will allow you to fix the contents of a 
damaged archive file.

Test:

Choosing Test from the Special sub menu will allow you to test the data integrity of 
the currently selected archive file.

UUEncode

Choosing UUEncode from the File Menu will Encode the selected files according to the 
current options for UUE files.

UUDecode

Choosing UUDecode options will decode the selected encoded files according to the 
current options for UUE files.

Path Setup

Choose Path Setup from the File Menu to display the Path Setup Dialog Box that will 
configure the DOS Path locations for the various programs used by CCIZip 2.0.  

Save Options

Chose Save Options from the File Menu to save the current options for each of the 
archive programs to the CCIZip 2.0 Initialization file.  These options will be used the 
next time CCIZip 2.0 is run. 

Shell Configuration

Choosing this item will display the Shell Configuration Dialog Box that will 
configure the speed and compression rate of ARJ compression.

Compression Type:

Choosing this item will display the Compression Type Dialog Box that will set 



the filter for all newly added files.

Date Filter:

Choosing this item will display the ARJ Date Filter Dialog Box that will set the 
date filter for newly added files.

Recursion:

Choosing this item will display the Recursion Dialog Box that will set the 
attributes that determine how the compression programs will store sub-
directories and the files within those sub-directories.

Save Volume Label:

Choosing this item will display the Volume Label Dialog Box that will select the
drive from which the volume label will be saved into the archive file.

Working Directory:

Choosing this item will display the Working Directory Dialog Box that will set 
the directory that the archive program will store its temporary files in.

Move:

Check this menu item to move(copy and then delete) the selected files into the 
archive file.

Password:

Check this menu item to password protect files as they are added to the archive 
file.  CCIZip 2.0 will prompt you for a password before the compression begins.

Uncompress Options:

Following are the options that can be set for the ARJ Uncompress Options menu 
item:

Extract To:

Choosing this item will display the Extract To Dialog Box that will set the 
output device for the extraction of data.

Uncompress Type:

Choosing this item will display the Uncompress Type Dialog Box that will set 



the filter for file extraction.

Create Subdirectories:

Check this menu item to create directories as needed in order to duplicate the 
original directory structure of the archived files.

Extract Volume Label:

Check this menu item to extract a volume label that is stored within the archive 
file and overwrite the current volume label.

Overwrite Existing Files

Check this menu item if it is OK to overwrite files that already exist during an 
extraction.

Password

Check this menu item to specify the password needed to uncompress files.  
CCIZip 2.0 will prompt you for a password before the extraction begins.



Directory Menu

Create Directory

Choose this menu item to create a new directory in the current browser.  The 
directory will be based off of the current directory in the browser.

Delete Directory

Choose this menu item to delete all selected directories and any other selected 
files in the current browser.  

Set Startup Directory

Choose this menu item to make the current directory in the browser the startup 
directory for that browser.  Every time you startup CCIZip 2.0, this directory 
will be the current directory of the browser.

Move Selected Files

Choose this menu item to move all of the selected files in the browser to the 
current directory of the opposite browser.

Refresh

Choose this menu item to redisplay the files in the current directory of the 
browser.

Select Wildcards

Choose this menu item to select multiple files by wildcard in the current 
directory of the browser.  Standard DOS wildcards are accepted ( * and $ ).

Select All

Choose this menu item to select all of the files in the current directory of the 
browser.



Archive Menu

The file extensions for every archive program are displayed in the Archive Menu.  The 
options for the selected archive program will be displayed in the Options Menu. 



Options Menu

The Options Menu displays the options for the archive program selected in the Archive 
Menu.  The title of the Options Menu will change according to the selection in the 
Archive Menu.  Following are the possible Option Menus that can be displayed:

ARJ Options
LHArc Options
PAK Options
PKZip Options
UUEncode Options
ZOO Options

LHArc Options

Compress Options

Following are the options that can be set for the LHArc Compress Options menu 
item:

Compression Type:

Choosing this item will display the Compression Type Dialog Box that will set 
the filter for all newly added files.

Recursion:

Choosing this item will display the Recursion Dialog Box that will set the 
attributes that determine how the compression programs will store sub-
directories and the files within those sub-directories.

Working Directory:

Choosing this item will display the Working Directory Dialog Box that will set 
the directory that the archive program will store its temporary files in.

Date Of Latest File:

Check this menu to set the date of the archive file to the date of the latest file 
contained within it.

Move:

Check this menu item to move(copy and then delete) the selected files into the 
archive file.



Store Only:

Check this menu item to store files in the archive file.  No compression will be 
performed.

Uncompress Options:

Following are the options that can be set for the LHArc Uncompress Options menu 
item:

Extract To:

Choosing this item will display the Extract To Dialog Box that will set the 
output device for the extraction of data.

Create Subdirectories:

Check this menu item to create directories as needed in order to duplicate the 
original directory structure of the archived files.

Extract Only Newer Files:

Check this menu item to only extract files that are newer then the files in the 
DOS directory.

Overwrite Existing Files

Check this menu item if it is OK to overwrite files that already exist during an 
extraction.

PAK Options

Compress Options

Following are the options that can be set for the PAK Compress Options menu item:

Compression Type:

Choosing this item will display the Compression Type Dialog Box that will set 
the filter for all newly added files.

Overwrite:

Choosing this item will display the Overwrite Dialog Box that will set the 
attributes that determine when to overwrite existing files within the archive file.



Working Directory:

Choosing this item will display the Working Directory Dialog Box that will set 
the directory that the archive program will store its temporary files in.

Comment Archive:

Check this menu item to add a comment to the archive file during all 
compression actions.

Comment Added:

Check this menu item to add a comment to each file that is added to the archive 
file.

Date Of Latest File:

Check this menu to set the date of the archive file to the date of the latest file 
contained within it.

Move:

Check this menu item to move(copy and then delete) the selected files into the 
archive file.

Password:

Check this menu item to password protect files as they are added to the archive 
file.  CCIZip 2.0 will prompt you for a password before the compression begins.

Recurse:

Check this menu item to recursively compress any selected directories.

Uncompress Options:

Following are the options that can be set for the PAK Uncompress Options menu 
item:

Extract To:

Choosing this item will display the Extract To Dialog Box that will set the 
output device for the extraction of data.

Overwrite:



Choosing this item will display the Overwrite Dialog Box that will set the 
attributes that determine when to overwrite existing files in the destination 
directory..

Create Subdirectories:

Check this menu item to create directories as needed in order to duplicate the 
original directory structure of the archived files.

Move:

Check this menu item to move(copy and then delete) the selected files into the 
current directory file.

Password:

Check this menu item to specify the password needed to uncompress files.  
CCIZip 2.0 will prompt you for a password before the extraction begins.

View Options:

Following are the options that can be set for the PAK View Options menu item:

View Comments:

Check this menu item to display the archive file comments when viewing the 
archive file.

PKZip Options

Compress Options

Following are the options that can be set for the PKZip Compress Options menu 
item:

Compression Algorithm:

Choosing this item will display the PKZip Compression Algorithm Dialog Box 
that will configure the speed and compression rate of PKZip compression.

Compression Type:

Choosing this item will display the Compression Type Dialog Box that will set 
the filter for all newly added files.

Date Filter:



Choosing this item will display the  PKZip Date Filter Dialog Box that will set 
the date filter for newly added files.

Recursion:

Choosing this item will display the Recursion Dialog Box that will set the 
attributes that determine how the compression programs will store sub-
directories and the files within those sub-directories.

Save Volume Label:

Choosing this item will display the Volume Label Dialog Box that will select the
drive from which the volume label will be saved into the archive file.

Working Directory:

Choosing this item will display the Working Directory Dialog Box that will set 
the directory that the archive program will store its temporary files in.

Comment Archive:

Check this menu item to add a comment to the archive file during all 
compression actions.

Comment Added:

Check this menu item to add a comment to each file that is added to the archive 
file.

Move:

Check this menu item to move(copy and then delete) the selected files into the 
archive file.

Password:

Check this menu item to password protect files as they are added to the archive 
file.  CCIZip 2.0 will prompt you for a password before the compression begins.

Uncompress Options:

Following are the options that can be set for the ARJ Uncompress Options menu 
item:

Extract To:



Choosing this item will display the Extract To Dialog Box that will set the 
output device for the extraction of data.

Uncompress Type:

Choosing this item will display the Uncompress Type Dialog Box that will set 
the filter for file extraction.

Create Subdirectories:

Check this menu item to create directories as needed in order to duplicate the 
original directory structure of the archived files.

Extract Volume Label:

Check this menu item to extract a volume label that is stored within the archive 
file and overwrite the current volume label.

Overwrite Existing Files

Check this menu item if it is OK to overwrite files that already exist during an 
extraction.

Password

Check this menu item to specify the password needed to uncompress files.  
CCIZip 2.0 will prompt you for a password before the extraction begins.

View Options:

Select this menu item to display the PKZip View Options Dialog Box in order to 
configure the sorting pattern when viewing a zip file.

UUEncode Options

Encoding Options:

Select this menu item to display the UUEncode Encoding Options Dialog Box in order to
configure the UUEncode program options.

ZOO Options

Compress Options



Following are the options that can be set for the ZOO Compress Options menu item:

Compression Type:

Choosing this item will display the Compression Type Dialog Box that will set 
the filter for all newly added files.

Move:

Check this menu item to move(copy and then delete) the selected files into the 
archive file.

Store FIles Only:

Check this menu item to store, not compress, files in the archive file.

Uncompress Options:

Following are the options that can be set for the ZOO Uncompress Options menu 
item:

Extract To:

Choosing this item will display the Extract To Dialog Box that will set the 
output device for the extraction of data.

Create Subdirectories:

Check this menu item to create directories as needed in order to duplicate the 
original directory structure of the archived files.

Extract Only Newer Files:

Check this menu item to only extract files that are newer then the files in the 
DOS directory.

Overwrite Existing Files

Check this menu item if it is OK to overwrite files that already exist during an 
extraction.

View Options:

Following are the options that can be set for the ZOO View Options menu item:



View Comments:

Check this menu item to display the archive file comments when viewing the 
archive file.

ARJ Compression Algorithm Dialog Box

Select one of the following levels of compression that are available through ARJ. These 
levels are:

Store Only

Data will simply be stored in the archive file, without compression.

Best Compression 

Data will be stored with the best compression for general use

Less Compression 

Data will be stored with slightly less compression, but it will be performed faster.

Less Compression, Less Memory, Faster 

Data will be stored with even less compression, less memory will be used and the 
compression will be performed faster.

Fastest Compression 

Data will be stored at the fastest possible rate.  This compression method results in 
the lowest compression ratio.

Arj Date Filter Dialog Box

Date Of Latest File

Mark this checkbox to set the date of the archive file to the date of the file with the 
latest date within the archive file.

Compress Files On Or After

Enter a date in the YYMMDD format.  Only files with a time stamp after that date 
will be added to the archive file.

Compression Type Dialog Box



Add

All selected files will be added to the archive file.

Freshen

A selected file will only be added to the archive file if there is already a file of the 
same name in the archive file and the selected file is newer.

Update

A selected file will be added to the archive file if it is not already contained in the 
archive file or if it is newer then a file of the same name that is already in the archive
file.

Recursion Dialog Box

Recurse Subdirectories

Mark this checkbox to recursively store directories in the archive file.  If a directory 
is chosen to be archived, all of its sub-directories will also be archived.

Store Pathnames

Mark this checkbox to store the path names of recursed files in the archive file.  This 
will enable files to be uncompressed into the same directory structure as they were 
compressed from.

Save Volume Label Dialog Box

Drive

Enter the letter of the drive whose volume label is to be saved into the archive file.

Working Directory Dialog Box

Specify Working Directory

Enter the path for the directory which the archive program will store its temporary 
files in.

Extract To Dialog Box

Files



Select this radio button to extract files to disk.

Screen

Select this radio button to extract files to the screen

Printer

Select this radio button to extract files to the printer

LPT1

Select this radio button to use printer device LPT1 when the printer radio button is 
selected.

LPT2

Select this radio button to use printer device LPT2 when the printer radio button is 
selected.

Uncompress Type Dialog Box

Default

Select this radio button to extract all selected files from the arcvhive file.

Only Newer

Select this radio button to extract only those files from an archive file that are more 
recent then a file of the same name on disk.  If the file does not exist on disk, it will 
be extracted.

Only Newer And Existing

Select this radio button to extract only those files from an archive file that are more 
recent then a file of the same name on disk.  The file must already exist on disk in 
order for the more recent file to be extracted from the archive file.

Convert Dialog Box

This dialog box will present you with a list of all possible archive file formats.  Choose 
the format that you wish each of the selected files to be converted to.

Overwrite Dialog Box



Write Over Always

Select this radio button to Always overwrite existing files when compressing or 
uncompressing.

Write Over Older

Select this radio button to only write over existing files that have an older file stamp 
than the file that it is to be overwritten by.

Prompt Write Over

Select this radio button to prompt the user before overwriting existing files.

Never Write Over

Select this radio button to never overwrite existing files.

PKZip Compression Algorithm Dialog Box

Maximal

Select this radio button to use the Maximal PKZip compression for each file.

Implode Only

Select this radio button to only use the PKZip Implode algorithm for all compressed 
files.

Shrink Only

Select this radio button to only use the PKZip Shrink algorithm for all compressed 
files.

PKZip Date Filter Dialog Box

Same Date:

Select this radio button to leave the date of the archive file unchanged after each 
compress action.

Current Date:

Select this radio button to set the date of the archive file to the current date after each
compress action.



Date Of Latest File:

Select this radio button to set the date of the archive file to the date of the latest file 
contained within it.

Compress Files On Or After:

Enter a date in the format of MMDDYY to only compress files with a date later than 
this date filter.

PKZip View Options Dialog Box

Display Comments

Select this check box to display comments stored in the zip file while viewing it.

View In Reverse Order

Select this check box to display the contents of the zip file in the reverse order of the 
selected sorting algorithm.

Date

Select this radio button to display the contents of the zip file sorted by the date of the
compressed files

Extension

Select this radio button to display the contents of the zip file sorted by the file 
extension of the compressed files

File Name

Select this radio button to display the contents of the zip file sorted by the file name 
of the compressed files

Original Order

Select this radio button to display the contents of the zip file in the original order that
they were compressed in.

Percent Compression

Select this radio button to display the contents of the zip file sorted by the 



compression ratios of the compressed files.

File Size

Select this radio button to display the contents of the zip file sorted by the size of the 
compressed files

UUEncode Encoding Options Dialog Box

UUEncode

Select this radio button to use the UUEncode encoding algorithms.

XXEncode

Select this radio button to use the XXEncode encoding algorithms.

Use Character Mapping Table

Select this radio button to use the Character Mapping Table encoding algorithms.

Calculate Line Checksums

Select this check box to calculate a checksum for each line in the encoded file.

Calculate Section Checksums

Select this check box to calculate a checksum for each section the an encoded file is 
broken up into.

Lines Per Section

Enter the maximum number of lines that each section of the encoded file will 
contain.  When encoding, the encoded file will be broken up into files that contain 
this number of lines.

Lines Of Padding In First Section

Enter the number of lines of padding to be placed in the first section of the encoded 
fille.

Shell Configuration Dialog Box

Hide Shell

Select this checkbox to run the CCIZip 2.0 shell Minimized in the background.  



You must run windows in 386 Enhanced mode in order to correctly use this 
option.  It is recommended that you configure the Compression programs to 
overwrite existing file.  If you do not, then the shell will be waiting for user input 
to determine if it is OK to overwrite existing files.  The shell can be maximized at 
any time by double clicking on its icon.

Pause Between Shell Commands

The CCIZip 2.0 shell program will prompt the user to 'Hit Any Key To Continue' 
after every shell command.  Select this checkbox to disengage this prompt.

Path Setup Dialog Box

Enter the directory/program names for the following items.  If the program is in your 
path, the program name will suffice.  Otherwise, you must enter the full path for the 
program.  If you do not have one of the programs, leave the entry blank.  When you hit 
OK from this dialog box, it will verify the location of each of the programs.

CCIZip Directory

Enter the location of the directory containing the CCIZip 2.0 program files.

CCIZip Temp Directory

Enter the directory that CCIZip 2.0 will use to store its temporary files.

Editor Program

Enter the name of the editor that CCIZip 2.0 will use to edit double clicked files.

PKZip Program

Enter the name of the PKZip compression program.

PKUnzip Program

Enter the name of the PKUnzip uncompression program.

PKZip Fix Program

Enter the name of the PKZip Fix utility program.

Self Extracting Program

Enter the name of the PKZip Zip-2-Exe conversion program.



LHArc Program

Enter the name of the LHArc program.

ARJ Program

Enter the name of the ARJ program.

PAK Program

Enter the name of the PAK program.

ZOO Program

Enter the name of the ZOO program.

UUEncode Program

Enter the name of the UUEncode program that is shipped with CCIZip 2.0.

UUDecode Program

Enter the name of the UUDecode program that is shipped with CCIZip 2.0.

Scan Program

Enter the name of the Scanning program.  CCIZip 2.0 is intended to work with the
McAffee Virus Scanning software.  However, it can be used with other programs 
also.  When you select an archive file to scan, CCIZip 2.0 will uncompress its 
contents in a temporary directory.  It will then execute  '<scan name> *.*'.  If you 
wish to use a program that has a different command line, you can write a batch 
file and insert a %1 where you would like the *.* to appear.  You can then specify 
the batch file name as the Scan Program.



Popup Menus
CCIZip 2.0 makes use of popup menus to provide object specific functionality.  All 
popup menus are activated clicking the right mouse button on the object. Popups can 
be activated for either of the two file browsers or for each individual file.

Browser Popups
File Popups

Browser Popups

A popup menu for a browser can be selected by clicking the right mouse button on 
the background (non-listbox area) of either of the browsers.  Following are the 
functions that can be performed on the browser:

Create Directory

Choose this menu item to create a new directory in the current browser.  The 
directory will be based off of the current directory in the browser.

Set Startup Directory

Choose this menu item to make the current directory in the browser the startup 
directory.  Every time you run CCIZip 2.0, this directory will the current 
directory of the browser.

Move Selected Files

Choose this menu item to move all of the selected files in the browser to the 
current directory of the opposite browser.

Refresh

Choose this menu item to redisplay the files in the current directory of the 
browser.

Select Wildcards

Choose this menu item to select multiple files in the current directory of the 
browser.  Standard DOS wildcards are accepted ( * and $ ).

Select All

Choose this menu item to select all of the files in the current directory of the 
browser.



File Popups

A popup menu for a file can be activated by clicking the right mouse button on that file.  
Following are the functions that can be performed on all files:

Duplicate

Select this menu item to duplicate the currently selected file. 

Rename

Select this menu item to rename the currently selected file.

UUEncode

Select this menu item to Encode the currently selected file. The encoded file will
have the same name with an extension of UUE or XXE.

UUDecode

Select this menu item to Decode the currently selected file.  The file must have 
been previously encoded with a compatable Encoding program.

Each archive file program has a unique set of functions.  The popup menus for each 
archive program will contain all of the above mentioned functions plus the unique 
functions that it can perform.

ARJ Popup Menu

Following are the options that can be performed on an ARJ file:

Comment

Choose this menu item to add comments to the files contained within the arhive 
file.

Make Self Extracting

Choose this menu item to make a self extracting executable for the currently 
selected archive file.

Test

Choose this menu item to test the integrity of the currently selected archive file.



LHArc Popup Menu

Following are the options that can be performed on an LHArc file:

Make Self Extracting

Choose this menu item to make a self extracting executable for the currently 
selected archive file.

Test

Choose this menu item to test the integrity of the currently selected archive file.

PAK Popup Menu

Following are the options that can be performed on an PAK file:

Comment

Choose this menu item to add comments to the files contained within the arhive 
file.

Convert Self Extracting

Choose this menu item to change the currently selected archive file into a self 
extracting executable file.

Test

Choose this menu item to test the integrity of the currently selected archive file.

PKZip Popup Menu

Following are the options that can be performed on an PKZip file:

Comment

Choose this menu item to add comments to the files contained within the arhive 
file.

Fix

Choose this menu item to fix the currently selected zip file that has errors in it.

Make Self Extracting



Choose this menu item to make a self extracting executable for the currently 
selected archive file.

Test

Choose this menu item to test the integrity of the currently selected archive file.

Zoo Popup Menu

Following are the options that can be performed on an PKZip file:

Comment

Choose this menu item to add comments to the files contained within the arhive 
file.

Test

Choose this menu item to test the integrity of the currently selected archive file.


